ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Fangame Creation > The Gourd of the Beans
The Gourd of the Beans
  Author    Thread Reply to topic
klownstein



Joined: 16 Dec 2010
Posts: 8
The Gourd of the Beans 

I've been working on this project, The Gourd of the Beans, off and on for a number of years. I've recently recruited some helpers to speed along the work and hope that they will significantly help speed my progression. I have a new website:

https://sites.google.com/site/klownstein/

where I hope to keep some relatively up-to-date info so all those interested can be informed of the progression. For those who have been following my work, check out the site and let me know what you think.

-klownstein

 Reply with quote  
Post Thu Dec 16, 2010 10:36 pm 
 View user's profile Send private message Visit poster's website
MusicallyInspired



Joined: 02 Mar 2007
Posts: 952
Location: Manitoba, Canada
 

That looks really interesting. And fun!

 Reply with quote  
Post Fri Dec 17, 2010 12:09 am 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

Looks really good. I've just added your site to my links page on www.agifans.com. Any chance I can convince you to switch to using the new PICEDIT for creating the picture resources?

 Reply with quote  
Post Sat Dec 18, 2010 4:53 am 
 View user's profile Send private message Visit poster's website
klownstein



Joined: 16 Dec 2010
Posts: 8
 

quote:
Originally posted by lance.ewing
Looks really good. I've just added your site to my links page on www.agifans.com. Any chance I can convince you to switch to using the new PICEDIT for creating the picture resources?


I've downloaded it and plan on giving it a go on my next background. Smile

-klownstein
 Reply with quote  
Post Sat Dec 18, 2010 9:57 pm 
 View user's profile Send private message Visit poster's website
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

Thanks. Let me know of any features you would like to see added.

 Reply with quote  
Post Sat Dec 18, 2010 11:07 pm 
 View user's profile Send private message Visit poster's website
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

I have to apologise in advance. I'm guessing you haven't started on that next AGI picture yet, but I've found a bug that is fairly big really. It actually generates a non-standard AGI picture. If you set the visual colour to white, it is currently adding colour 16 into the picture code buffer. It will do the same thing if you set the priority colour to red.

This bug was introduced with one of the last features I added, which was the background image tracing feature. It might seem like a fairly weird bug but it is due to the way I keep track of the transparent colour. White is transparent on the visual screen and red is transparent on the priority screen.

It's a quick fix to fix this issue, so I'll update it now and release beta 2. Note that this fix will not have any of the newer features I've been working on since those are not fully tested yet. The beta 2 release will be exactly the same as beta 1 except that it will include this fix.

I'll report back when beta 2 is uploaded to my site.

 Reply with quote  
Post Sun Dec 19, 2010 10:31 pm 
 View user's profile Send private message Visit poster's website
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

ARGGGGHHHH!! I just found an even bigger bug. A much, much bigger bug. The set priority colour and turn off priority colour actions are adding the wrong codes to the picture code buffer. They are adding the corresponding visual colour codes instead, e.g. set priority is actually setting the visual colour (not that you notice until you load and save the picture).

Classic copy and paste error.

 Reply with quote  
Post Sun Dec 19, 2010 10:44 pm 
 View user's profile Send private message Visit poster's website
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

And a third bug. Not quite as bad this time but picture navigation is not the best when on the priority screen. It keeps switching to the visual screen.

I'll fix all three bugs while I'm at it. Not sure why I didn't see any of these until now.

 Reply with quote  
Post Sun Dec 19, 2010 11:11 pm 
 View user's profile Send private message Visit poster's website
lance.ewing



Joined: 11 Dec 2010
Posts: 56
Location: www.agifans.com
 

I have just uploaded beta 2 to my web site. Grab that version to draw your next picture with.

 Reply with quote  
Post Mon Dec 20, 2010 12:08 am 
 View user's profile Send private message Visit poster's website
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge