ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Wii Port > ScummVM Channel FINAL - IOS58 Support / SVN / Download Now! Goto page Previous  1, 2, 3, 4  Next
ScummVM Channel FINAL - IOS58 Support / SVN / Download Now!
  Author    Thread Reply to topic
obcd



Joined: 09 Nov 2010
Posts: 19
 

I did some further checking:
Launching
Wiixplorer using IOS 58 works fine
Forwarder using IOS 36 does mount USB drive on second attempt.
HBC 1.0.8 using IOS58 refuses to mount the USB drive.
Bootmii using IOS36 does mount USB drive on second attempt. Doesn't fill in the program argument list.
Nforwarder58 using IOS58 mounts USB drive on second attempt.

The behavour of the programs using IOS36 looks consistent. It's probably using USB 1.1 in that case.

The behavour when using the HBC 1.0.8 is very strange.

Sorry for getting a little off topic with this post.
Maybe I can let the Channel launch the nforwarder58 (small program so it shouldn't take much time) and let that one load the scummvm program. Or maybe I will just wait for the new channel that hopefully uses IOS58. I just noticed that the title of this topic says that there is IOS58 support. Maybe I am using the older one?
The iosses I mention here are those reported by scummvm.

 Reply with quote  
Post Fri Dec 10, 2010 10:31 pm 
 View user's profile Send private message
raschi



Joined: 23 Jan 2006
Posts: 45
 

quote:
Originally posted by Red_Breast
Wasn't that WiiMC ios 202 a custom ios to unlock USB 2.0? The one made by KWiirk? Just trying to find it on Wiibrew I see the page has been deleted.
Team Twiizers recent addition of USB 2.0 is much more elegant as it uses Nintendo's USB 2.0 which had been introduced with one of the balance board games.


This is true, but the old forwarder doesn't use ios58.
I thought maybe the old forwarder could take advantage of ios202. Besides it doesn't hurt to have it installed for homebrew that still doesn't use ios58.

quote:
Originally posted by obcd
I did some further checking:
Launching
Wiixplorer using IOS 58 works fine
Forwarder using IOS 36 does mount USB drive on second attempt.
HBC 1.0.8 using IOS58 refuses to mount the USB drive.
Bootmii using IOS36 does mount USB drive on second attempt. Doesn't fill in the program argument list.
Nforwarder58 using IOS58 mounts USB drive on second attempt.

The behavour of the programs using IOS36 looks consistent. It's probably using USB 1.1 in that case.

The behavour when using the HBC 1.0.8 is very strange.

Sorry for getting a little off topic with this post.
Maybe I can let the Channel launch the nforwarder58 (small program so it shouldn't take much time) and let that one load the scummvm program. Or maybe I will just wait for the new channel that hopefully uses IOS58. I just noticed that the title of this topic says that there is IOS58 support. Maybe I am using the older one?
The iosses I mention here are those reported by scummvm.


Maybe WiiXplorer has been compiled with a newer version of libogc, with better detection of different usb drives? Maybe it has a better implementation for detecting usb drives overall?
I believe HBC has some issues with some usb drives.
Can you try a different hdd?
 Reply with quote  
Post Sat Dec 11, 2010 8:43 am 
 View user's profile Send private message
tirges



Joined: 24 Mar 2009
Posts: 6
 

Wow, thanks for getting off-topic and mentioning starting ScummVM through WiiXplorer ...

Had crashes runnung through HBC (IOS58) and accessing the USB (IOmega 1TB thingy).
I thought I was just out of luck, but running through WiiXplorer works flawlessly...


Can't wait for the new forwarder Smile

 Reply with quote  
Post Mon Dec 13, 2010 1:06 am 
 View user's profile Send private message
Mr_Nick666



Joined: 11 Apr 2007
Posts: 146
Location: Bideford, Devon, UK
 

New logos added and all working ok. Download now available at first post Cool

To all using the older builds and complaining. WHY!? I said the new one was coming! All your issues should be fixed with this download (it all worked in our tests). Wink

 Reply with quote  
Post Thu Dec 23, 2010 9:06 am 
 View user's profile Send private message Visit poster's website
obcd



Joined: 09 Nov 2010
Posts: 19
old build complains 

Thanks Mr_Nick666.

I had the impression the older version was removed because it used the older Scummvm logo with the small s. As the homebrew channel wasn't launching the program as expected as well, the only reliable way I found was launching wiixplorer from the HBC and the scummvm boot.dol from wiixplorer. This is not exactly an easy way to explain to my 9 year old daughter. So I thought, who cares about that s, I use the existing channel and replace it when the new one is ready. I didn't realise that I got the really old one that wasn't using ios 58 yet. I only started the discussion to find out why the program had problems to mount my usb disk when it was launched from that same usb disk. This wasn't a problem unique to your channel. My apologies, it was definite not my intention to bring your channel launcher in discredit.

 Reply with quote  
Post Thu Dec 23, 2010 10:33 pm 
 View user's profile Send private message
raschi



Joined: 23 Jan 2006
Posts: 45
 

Thanks. Works great Very Happy

 Reply with quote  
Post Fri Dec 31, 2010 12:52 am 
 View user's profile Send private message
KainXVIII



Joined: 11 Feb 2008
Posts: 35
Location: Russia
 

I can't install it through Yet Another Wad Manager gives me
Error -1035

 Reply with quote  
Post Sat Jan 01, 2011 12:54 pm 
 View user's profile Send private message
MusicallyInspired



Joined: 02 Mar 2007
Posts: 949
Location: Manitoba, Canada
 

You need to have the right IOS. Unfortunately, 4.3 doesn't have it. I haven't been able to install a WAD in a long time because of this and I haven't been able to get it to work.

 Reply with quote  
Post Sat Jan 01, 2011 4:19 pm 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
KainXVIII



Joined: 11 Feb 2008
Posts: 35
Location: Russia
 

quote:
Originally posted by MusicallyInspired
You need to have the right IOS. Unfortunately, 4.3 doesn't have it. I haven't been able to install a WAD in a long time because of this and I haven't been able to get it to work.

Which IOS? I presume i have them all Shocked
 Reply with quote  
Post Sun Jan 02, 2011 9:18 am 
 View user's profile Send private message
MusicallyInspired



Joined: 02 Mar 2007
Posts: 949
Location: Manitoba, Canada
 

Hah. No. You can only have one at a time. I can't remember which, but there's only one IOS that will allow you to install custom WADs and it's extremely hard to get if you've already upgraded to System Menu 4.3 (don't confuse IOS's with System Menu versions) and involves downgrading which is dangerous.

Likewise, there's only one IOS (IOS58) that will allow you to ustilize USB 2.0 speeds.

 Reply with quote  
Post Sun Jan 02, 2011 1:42 pm 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
KainXVIII



Joined: 11 Feb 2008
Posts: 35
Location: Russia
 

quote:
Originally posted by MusicallyInspired
Hah. No. You can only have one at a time. I can't remember which, but there's only one IOS that will allow you to install custom WADs and it's extremely hard to get if you've already upgraded to System Menu 4.3 (don't confuse IOS's with System Menu versions) and involves downgrading which is dangerous.

Likewise, there's only one IOS (IOS58) that will allow you to ustilize USB 2.0 speeds.

I can install other channek forwarders (wiiflow, usb gx loader, vba emul), why i can`t install subj?
PS - and i have ios58 too..
 Reply with quote  
Post Sun Jan 02, 2011 9:30 pm 
 View user's profile Send private message
Mr_Nick666



Joined: 11 Apr 2007
Posts: 146
Location: Bideford, Devon, UK
 

Try using WAD Manager 1.7. It's what I used to install mine. Smile

 Reply with quote  
Post Mon Jan 03, 2011 3:49 pm 
 View user's profile Send private message Visit poster's website
KainXVIII



Joined: 11 Feb 2008
Posts: 35
Location: Russia
 

quote:
Originally posted by Mr_Nick666
Try using WAD Manager 1.7. It's what I used to install mine. Smile

I use this too, which ios you choose at the begining?
 Reply with quote  
Post Mon Jan 03, 2011 9:59 pm 
 View user's profile Send private message
MusicallyInspired



Joined: 02 Mar 2007
Posts: 949
Location: Manitoba, Canada
 

quote:
Originally posted by Mr_Nick666
Try using WAD Manager 1.7. It's what I used to install mine. Smile


Do you also have system menu 4.3? I've tried 1.7 before, I believe, and it won't work for me. Even if I choose IOS249. It just freezes and I have to force a restart.
 Reply with quote  
Post Mon Jan 03, 2011 11:03 pm 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
raschi



Joined: 23 Jan 2006
Posts: 45
 

Try this:
Download and run IOS 236 Installer.
Download and run Anytitle Deleter MOD, and make sure it uses the newly installed IOS 236.
Uninstall the old ScummVM Channel(SCUM) with Anytitle deleter.
Use Wadmanger 1.7 with IOS 236 to install the new ScummVM Channel.

 Reply with quote  
Post Tue Jan 04, 2011 10:55 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2, 3, 4  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge