ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Help and Support > Monkey Island 2 - background Midi's overlapping? Goto page 1, 2  Next
Monkey Island 2 - background Midi's overlapping?
  Author    Thread Reply to topic
Sierra13



Joined: 17 Jun 2008
Posts: 2
Monkey Island 2 - background Midi's overlapping? 

Hello,

First, i would like to thank the SCUMMVM community for this wonderful s/w. I've known SCUMMVM for quite a while but last week in particular was a good week for me and SCUMMVM.
I finished Monkey Island 1 while Mass Effect for the PC stood in the corner (and i didn't play the 360 version...).

If you may, i have an odd question concerning Monkey Island 2.
My version is DOS/English. While playing the game i noticed that there is an underlying sound track that continues to play also when the front music changes.
Its like the game has a constant background track and a location specific track and they play together.

Is this normal?
A good example would be the map screen which has its own track.

Thank you,
Sierra13

 Reply with quote  
Post Tue Jun 17, 2008 6:58 pm 
 View user's profile Send private message
md5
ScummVM Developer


Joined: 03 Nov 2005
Posts: 2256
Location: Athens, Greece
 

Hello

This is quite an old bug with MI2, check here:
http://sourceforge.net/tracker/index.php?func=detail&aid=884000&group_id=37116&atid=418820

This bug can't be reliably reproduced, hence its hard to fix it Sad

 Reply with quote  
Post Tue Jun 17, 2008 7:32 pm 
 View user's profile Send private message
Sierra13



Joined: 17 Jun 2008
Posts: 2
 

2004. wow. good catch.
Well, understand it better now. i will try to persevere.
many thanks!

Well, at least using "imuse stop all" resets the music and puts it back to normal so at least there is a workaround.

 Reply with quote  
Post Tue Jun 17, 2008 8:05 pm 
 View user's profile Send private message
Stratoukos



Joined: 18 Sep 2009
Posts: 2
 

Reviving an old thread here, but exactly the same thing happened to me.

The music from the carnival in booty island loops endlessly in the background and any other music track plays normally on top of the booty track.

"imuse stop all" fixed it for me but as I see it's a difficult bug to reproduce, so I can provide a save file if it will be of any help.

 Reply with quote  
Post Fri Sep 18, 2009 10:15 pm 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3286
 

quote:
Originally posted by Stratoukos

"imuse stop all" fixed it for me but as I see it's a difficult bug to reproduce, so I can provide a save file if it will be of any help.


A save game from after the problem has happened probably isn't much help, unfortunately. It only shows the current state of things, not how they came to be.
 Reply with quote  
Post Sat Sep 19, 2009 6:22 am 
 View user's profile Send private message
Raziel
ScummVM Porter


Joined: 25 Oct 2005
Posts: 901
Location: A haunted Castle somewhere in the Bavarian Mountains
 

Maybe he got a savegame right before booty island?

 Reply with quote  
Post Sat Sep 19, 2009 8:27 am 
 View user's profile Send private message Visit poster's website
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3286
 

quote:
Originally posted by Raziel
Maybe he got a savegame right before booty island?


That may or may not help. After all, many have played that part of the game without triggering the bug, so it probably only happens under specific circumstances.

(One thing that used to trigger it in the distant past was changing between rooms very quickly, but I only managed to reproduce that when using the "fast mode" feature. And since that is documented to cause trouble in some cases, it doesn't really count.)
 Reply with quote  
Post Sat Sep 19, 2009 8:34 am 
 View user's profile Send private message
Stratoukos



Joined: 18 Sep 2009
Posts: 2
 

Well I don't have a save from before the problem occurred. I don't know if it helps but I had the game on pause (space) for a really long time, but I am not 100% sure if this problem happened before or during the pause.

I have played the game again on v0.12 (now I am on 1.0.0rc1) with the same data files without having this problem

Well here is the save if anyone is interested.

 Reply with quote  
Post Sat Sep 19, 2009 2:05 pm 
 View user's profile Send private message
LogicDeLuxe



Joined: 10 Nov 2005
Posts: 366
 

This is a obviously bug in the original game. Bits of any music can loop endlessly. I've seen it happen a few times, including the Amiga version. This is very rare, though. And I don't know how to reproduce this.

 Reply with quote  
Post Sat Sep 19, 2009 4:42 pm 
 View user's profile Send private message
Raziel
ScummVM Porter


Joined: 25 Oct 2005
Posts: 901
Location: A haunted Castle somewhere in the Bavarian Mountains
 

quote:
Originally posted by Stratoukos
Well I don't have a save from before the problem occurred. I don't know if it helps but I had the game on pause (space) for a really long time, but I am not 100% sure if this problem happened before or during the pause.

I have played the game again on v0.12 (now I am on 1.0.0rc1) with the same data files without having this problem

Well here is the save if anyone is interested.


WOW, now THATS what i call overlapping music cues :-/
Immediately after loading the state i got two cues overlapping, entering the cemetary makes it worse as the cemetary cue gets added to the kakophonie, sounding bad, bad, baaad...by the way, the speed when "cemetary" or any other location is displayed goes to it's knees...strange

I also got a WARNING i never got before
WARNING: Trying to use unsupported effect level value 64 in native MT-32 mode. Please report this!!
but my MT-32 isn't playing anything, could be a coincidence because @Stratoukos isn't using a real MT-32???
(edit: my bad, i had it set to override global settings, changed it back, but still music cues overlapping ti its max Sad)
Anyway i don't think this save is helpful as it seems the flags are already messed up to the top
 Reply with quote  
Post Sun Sep 20, 2009 8:27 am 
 View user's profile Send private message Visit poster's website
LordHoto
ScummVM Developer


Joined: 30 Oct 2005
Posts: 1030
Location: Germany
 

That's a recently introduced warning. It is harmless, probably you got it because of an old save state or savestate not made with native MT-32 mode.

 Reply with quote  
Post Sun Sep 20, 2009 12:10 pm 
 View user's profile Send private message
monkeyloop



Joined: 30 Dec 2009
Posts: 2
 

quote:
Originally posted by Sierra13
Well, at least using "imuse stop all" resets the music and puts it back to normal so at least there is a workaround.

Sorry for the stupid question, but where do I type this command?
 Reply with quote  
Post Wed Dec 30, 2009 1:04 am 
 View user's profile Send private message
LordHoto
ScummVM Developer


Joined: 30 Oct 2005
Posts: 1030
Location: Germany
 

quote:
Originally posted by monkeyloop
quote:
Originally posted by Sierra13
Well, at least using "imuse stop all" resets the music and puts it back to normal so at least there is a workaround.

Sorry for the stupid question, but where do I type this command?


In the debugger, which you should be able to bring up with Ctrl+D.
 Reply with quote  
Post Wed Dec 30, 2009 1:10 am 
 View user's profile Send private message
monkeyloop



Joined: 30 Dec 2009
Posts: 2
 

Thanks, that worked! I think I had at least 3 tracks playing at the same time, what a mess...

 Reply with quote  
Post Wed Dec 30, 2009 12:35 pm 
 View user's profile Send private message
ps3d



Joined: 18 Jan 2010
Posts: 6
 

OK, here's what I found on playing it.

- It is NOT the fault of ScummVM. It is a glitch in the game.
- I found it after staying in the "Villa de la Booty" town more than around 15 seconds.
- Am using Macintosh OS 9, real program (not SCUMMVM)
- Only occurs on Full Mode (not Lite)

I can't access a debugger, though there is a file named "iMuse Setup". Can anyone help me out?

 Reply with quote  
Post Mon Jan 18, 2010 11:35 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page 1, 2  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge